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Purpose 
 
Mini Translator is a set of tools designed to produce human readable formats out of EDI data files. It is mini translator, EDI 
standards database and report generator rolled into one.  
Typical translators are designed to produce or consume EDI files in order to make other computer systems talk to each other. Mini 
Translator is designed to take an EDI file and produce one of easier to read formats like CSV. It uses slim down version of 
database with EDI standards to find names and meaning of most of EDI constants. 
 
Supported EDI standards include EDI X12 4010, 4020, 4030, 4040, 4050, 4060, 5010, 5020 and 5030. Product supports all 
HIPAA message types. Other EDI standards such as EDI X12 6010 have also been tested and should work as well. 
 
Mini Translator is simplified version of Extreme Translator product. It is designed to produce basic EDI data outputs without need 
for you to learn how to create translation maps for them. Mini Translator performs auto-map internally and creates translation map 
for you. However this simplification means that number of features available in Extreme Translator are not available in Mini 
Translator. If you find Mini Translator lacking please take a look at Extreme Translator product. 
 
Requirements 
 
Minimum Requirements  
Software Windows 2000/XP/Vista/Server 2003/7 
Hardware Pentium 1GHz, RAM 256Mbt 
  
Recommended   
Software Windows XP Pro 
Hardware Pentium 1.5GHz, RAM 512Mbt 
 
Package Details 
 
Package comes as setup program for Windows based personal computers. Software product does not install any separate 
runtimes or systems and does not require them to be preinstalled. Example: software does not use .NET or Java runtimes and 
does not need them preinstalled.  
 
We recommend to always use setup program to install product on new computer.  
 
Once installed product creates following important files: 

1. Mini.exe – main program. 
2. MiniCmd.exe – command line batch type translation runner. 
3. Mini.pdf – Users Manual documentation. 

 
Licensing 
 
Default package installation comes as time limited trial evaluation license. After fixed number of days starting from the day of the 
first use, trial evaluation license will expire and most of software features will become disabled. If you like the product and 
purchase it, you will receive permanent license key. This new key must be entered in License dialog: 
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License key should be entered via Help->License menu in Mini Translator main screen. Both “License To” and “License key” fields 
are required. 
 
If you let trial version to expire this will eventually stop software from processing data. Once you decide to purchase the product, 
you will receive new permanent license key you can enter in the License screen. This new key will unlock the product without a 
need to reinstall it. 
 
If you like the product and decide to purchase it, you will receive new permanent license key that will never expire. Simply enter or 
copy and paste new license key in Help->License screen, and restart the program. Same permanent license key can be used to 
run translations via command line. However you need special developer license to integrate translator runtime into your programs 
and use Developer SDK. 

 
Main Program 
 
You can preview and create output EDI files using main program. Use ”File->Open And Translate” menu or Open toolbar button to 
open EDI file. 
Mini Translator creates output file into the same directory as input file but sets output file extension to “.csv” and adds “_out” to the 
end of file name. Example: if your input file is called “my271.edi” your output file name will be “my271_out.csv”. 
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There is main Mini Translator screen. You can simply drop your EDI files on it. 
 

 
There are number of options available when opening EDI files. Default options are setup so file would easily open in Microsoft 
Excel or other program that can display typical CSV files. 
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Translation Configuration 
 
You can save translation configuration and modify it via Edit Translation Configuration toolbar or menu option.  
If you do not click Edit Translation Configuration after you run specific EDI X12 file for the first time, then translation configuration 
is left unsaved. 
 

 
At the start of processing translator reads EDI transaction number, standard information and sender Id from ISA, GS and ST 
segments of the EDI X12 file. Combination of those 3 fields forms message “identity”. All EDI X12 files with same identity have the 
same features. Therefore translation configurations are saved based on EDI X12 file identity (based on combination of 
transaction_standard_senderId). 
 
So you may have two EDI X12 837 files from the same sender but they would be based on different standards therefore they will 
have different “identity” and different translation configurations. 
Obviously you may have 270s, 834s and 837s from the same sender and based on the same standard but since they are different 
transactions they will have different translation configurations as well. 
 
Translation configuration saves field names, flag for disabled fields and “Use Previous If Empty” flag. You can change all of those 
options.  
 
If “Use Previous If Empty” flag is True it tells translator to repeat value of the header information from previous row of the flat file 
into current row. This is mostly used for header fields that contain information that has to be repeated for each new row of the flat 
file. 
 
When translator creates initial translation configuration for the first time it performs following optimization steps: 
1. “Use Previous If Empty” flag is set to True on header fields. 
2. Fields that do not have any data in them by default set as disabled (unchecked).  
3. Most qualifier and identifier fields by default set to disabled. 
4. Field names set to names defined in small EDI X12 standards database that comes with translator. 
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After you open Edit Translation Configuration screen Mini Translator saves that translation configuration and uses it for future 
translations. “Use Previous If Empty” for this field is set to True, that means translator will repeat this fields value on every row of 
CSV if there is no new value for this particular field. You can change “Use Previous If Empty” to False if you do not want that value 
repeated on every row. 
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This field has also “Use Previous If Empty” set to True and it repeats its value for every row of CSV file. But in EDI file there is only 
one value for “STATE OF FLORIDA MEDICAID”. 
 
Initially when translation configuration is created translator tries to make intelligent guess what fields should have they values 
repeated and have “Use Previous If Empty” set to True. Translator performs EDI loop analysis and then sets “Use Previous If 
Empty” to True on fields that are mostly header fields. You can change all of those flags in translation configuration. 
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There is where you set “Use Previous If Empty” for this field to True. 
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Translator uses segments with qualifiers to find specific data in the file. Then it saves that search information into Id property 
stored in the translation configuration. You can see Id property in the list just below “General”. 
 



Mini Translator 

Etasoft Inc. Page 10 5/11/2012 

Now look at the actual EDI X12 sample file below to see how this information looks inside EDI X12 file. 
 

 
Segment is DTP and segment qualifier is 356. Look at the previous screenshot and notice how “Id” property contains DTP*356. 
 
Processing Modes 
 
There are two processing modes: 
 
1. "Free run" mode. In this mode translator is allowed to just take any EDI file and use its own discretion on output. 
If you simply run Mini Translator and do NOT use Translation Configuration then it detects fields and decides which ones to 
show/not show, etc. Therefore on each new file set of fields may differ. 
Because you do not use Translation Configuration each file is new file for the translator. It performs field discovery on every run. 
 
2. "Frozen fields" mode. 
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When you process file from Trading Partner first time, make sure to open Translation Configuration. Then it will "freeze" columns 
for that Trading Partner. 
Each Trading Partner gets different Translation Configuration. 
Once you open Translation Configuration and click OK, number of columns is fixed for that particular Trading Partner. You can 
enable/disable columns but they location will not change on every execution unless you change it. 
 
Batch Command Line Processing 
 
You can run mini translator as command line batch job. But first you need to execute main Mini Translator GUI at least once. It will 
register license key and EDI standards database. 
 
"C:\full_path_to_executable\minicmd.exe" -i "C:\test\input270.txt" -o "C:\test\input270_cmd.csv" 
 
Here “-i” followed by space and input file name in double quotes is input file. 
“-o” followed by space and output file name in double quotes is output file. 
If you do not provide “-o” parameter then translator will create output file name based on input file name with extension “.out”. 
 
Other options such as field separators, use of quotes, etc. are by default taken from settings set via main Mini Translator GUI. 
Command line runner returns 0 if processing run without errors. Non-zero exit code indicates error. 
 

 
There is command line execution in action. 
 
On some installations command line runner can not find settings set via main Mini Translator GUI and will give you “Not licensed” 
error. In that case you need to pass path where settings are into command line runner using –u parameter. Parameter -u takes 
directory where Mini Translator has EDI Standards database and "settings.json" files installed. You can find this directory on most 
computers by simply typing  
echo %AppData%  
in the command line. Environment variable %AppData% + subfolder “Mini Translator” should give you string you need to type for 
parameter –u. 
 

 
Pass command line –u option that points to settings set via main Mini Translator GUI. This is only required if command line runner 
can not find settings set via Mini Translator GUI. 
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Mini Translator command line runner returns 0 (zero) if there are no errors during processing. Any other return value indicates 
error. 
 
You can also process all files in specific directory. This is done using wildcard patterns in input file name. 
"C:\full_path_to_executable\minicmd.exe" -i "C:\test\*.txt" 
Following command line will process all the files in directory C:\test that have extension “*.txt”. Do not supply output file name as 
translator will create output file names based on input file names it finds using wildcard pattern. 
 
What Are Invalid EDI Files? 
 
Once you open EDI file in some text editor like Notepad, it looks cryptic. However all valid EDI X12 files have same properties: 

1. They all start with three letters: “ISA” 
2. After 103 characters there is word “GS”. Sometimes “GS” is on the second line. If “GS” is on the second line then there 

might be only 102 characters between “ISA” and “GS”. 
 
Mini Translator reads and breaks down EDI files using these two points above. Most common scenarios why Mini Translator might 
not be able to process the file: 
 

1. That is not an EDI X12 file. Period. It is flat file, XML or scanned print image form or something else but EDI file. 
 

2. If you copy and paste EDI file from Internet Browser window in most cases resulting EDI file will not be valid anymore. 
This is due to how spaces are displayed in the Browsers. Instead of 103 characters between ISA and GS you might end 
up having much less. 
 

3. Usually EDI files are sent over secure connections using encryption/decryption communications. Sometimes not just 
communications but EDI files are encrypted themselves. Encryption leaves ISA/GS part valid but all segments in the file 
unreadable. Unless EDI file is decrypted Mini Translator will not be able to read it correctly. 
 

4. Some EDI files come from mainframe computer systems. Occasionally they are formatted into columns of 80 characters 
long. Extra carriage return and line feed characters break segments into multiple lines making EDI file invalid. Those files 
can not be processed. 
 

5. Rarely EDI software communication packages combine multiple EDI messages of various types into one file. There are 
two variations of this combination: 
 

a) Example: 810 invoices and 997 acknowledgements with the same separators in one file. This is valid EDI file however 
output of Mini Translator might not look right. Because Mini Translator will try to flatten EDI loops and encounter few loops 
repeating independent of each other (as per example above: 810 invoices will repeat separately from 997 loops). It is like 
trying to combine two spreadsheets that have no common fields; at the end combined spreadsheet will have mix of lines 
that do not tie up. 
 

b) Example: 810 invoices and 997 acknowledgements with the different separators in one file. This is not possible to 
process. Mini Translator detects separators at the start of the EDI file. If separators change somewhere in the middle of 
the file Mini Translator will continue processing the file using old separators found at the file start. Scenario when various 
EDI messages are mixed in one file with different separators is very rare but we mention it here to complete possible list 
of files that can not be processed.  

 
 
Looping and Processing Details 
 
Mini Translator uses compact database with EDI information to look up number of codes and values you see in a typical EDI file. 
This allows creation of the output that contains human readable text instead of 2-3 letter codes.  
 
Mini Translator also tries to create flat structure out of looping EDI hierarchies. As a result EDI header fields repeat they values for 
every new line of the output file. New line in the output is created when nested EDI loop repeats.  
 
Creating flat structure out of looping EDI messages with many nested hierarchical levels is not a trivial task. Flat structure is 
created by repeating header and trailer field values while creating new values of detail fields on each new output line. Mini 
Translator performs looping structure analysis as first processing step. Result of this analysis is how many output lines or columns 
are created in the output file.  
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Change looping 
 
Starting with version 3.130 you can change how translator handles looping. It adds simple dialog screen that allows you to enter 
looping rules.  
 

 
Current default looping rules are:  
HL_22,CLP,INS,HL_PT,NM1_QC  
 
What does it mean? It means that for example if translator encounters HL_22 segment in EDI file it has to create new row in CSV.  
Default rules setup to produce most common outputs for various EDI files. But you can alter them. This is very powerful feature 
that gives you additional CSV output customization.  
 
Each rule is separated by comma.  
835 example:  
SVC ,HL_22,CLP,INS,HL_PT,NM1_QC  
Notice SVC rule added. This will force translator to create new CSV row for every SVC (service line segment in 835).  
 
837 example: 
SV1,SV2,HL_22,CLP,INS,HL_PT,NM1_QC 
Notice SV1,SV2 added. This will force translator to create new CSV row for every service line in 837. 
You can also try: 
LX,HL_22,CLP,INS,HL_PT,NM1_QC 
 
271 example: 
NM1_IL,HL_22,CLP,INS,HL_PT,NM1_QC 
Notice NM1_IL added before HL_22. In some 271s you might want to get more rows in CSV output. This should do it. 
 
Downside is that you need to delete all your current translation configurations before you alter these looping rules. Use "Edit 
Translation Configuration" and "Delete All". Then go to Edit->"Looping Rules". 
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Some rule changes break translation and produce formats with fields shifted into incorrect rows. Do not make changes to the 
looping rules unless you have to. Default rules have been tested and work for majority of EDI formats. Therefore it is best to leave 
default rules unless you really need translator output changed. 
 
Results 
 
After successful execution Mini Translator produces files in number of formats. Some formats like CSV can be open in popular 
spreadsheet programs such as Microsoft Excel. You might need to move and resize spreadsheet columns to see all the data 
properly. 
Keep in mind that spreadsheet programs have certain limitations on how many columns and rows they can display or how big of 
spreadsheets they can handle. Some have hard set limits of no more than 256 columns and no more than 16384 rows. 
If your EDI file contains hundred thousand segments you might not be able to open it in a typical spreadsheet program. It is 
limitation of spreadsheet program and not of Mini Translator. 
 
Performance 
 
Mini Translator reads and parses EDI files in computer memory. That puts certain limits on how big input EDI files it can process. 
Also since output report files are more verbose than input EDI files total output size could be 7-10 times greater than input size. 
Example: if your input EDI file is 4Mbt your CSV output file might be around 30Mbt. This is due to the fact that flat files contain 
many repeating values. 
 
Developer SDK 
 
Look under DeveloperSDK subfolder below Mini Translator installation main folder. 
 
Technical Support 
 
Please contact technical support if you have any questions or concerns. Contact information is listed on the product and company 
websites. 


