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eTranslator
Purpose

eTranslator is bidirectional translator for EDI <-> XML translations. You can manipulate resulting XML files, load them into
databases and translate back into EDI X12.

Supported EDI standards include EDI X12 4010, 4020, 4030, 4040, 4050, 4060, 5010, 5020 and 5030. Product supports all
HIPAA message types. Other EDI standards such as EDI X12 6010 have also been tested and should work as well.

eTranslator is simplified version of Extreme Translator product. It is designed to produce basic EDI data outputs without need for
you to learn how to create translation maps for them. eTranslator performs auto-map internally and creates translation map for
you. However this simplification means that number of features available in Extreme Translator are not available in eTranslator. If
you find eTranslator lacking please take a look at Extreme Translator product.

eTranslator creates XML format out of EDI files in a way so it could be assembled back into original EDI file. Therefore XML
format contains XML tags hamed in a special way as to allow translation back into original EDI format. You can not just drop any
XML file and expect it translated into EDI. Your first file must be EDI file. Only then that XML file can be translated back into EDI.

Requirements

Minimum Requirements

Software Windows 2000/XP/Vista/Server 2003/7
Hardware Pentium 1GHz, RAM 256Mbt
Recommended

Software Windows XP Pro

Hardware Pentium 1.5GHz, RAM 512Mbt

Package Details

Package comes as setup program for Windows based personal computers. Software product does not install any separate
runtimes or systems and does not require them to be preinstalled. Example: software does not use .NET or Java runtimes and
does not need them preinstalled.

We recommend to always use setup program to install product on new computer.
Once installed product creates following important files:
1. etran.exe — main program.
2. etrancmd.exe — command line batch type translation runner.
3. etran.pdf — Users Manual documentation.
Licensing
Default package installation comes as time limited trial evaluation license. After fixed number of days starting from the day of the

first use, trial evaluation license will expire and most of software features will become disabled. If you like the product and
purchase it, you will receive permanent license key. This new key must be entered in License dialog:
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License Information &J

License Information

Copyright (C) 2011, Etasoft Inc,

eTranslator
Licensed to : John Dogl
License key : 5b416 1df20450525771140e216576b 3604 e

If you enter new license key, restart the program for changes to take effect

oK ] I Cancel

License key should be entered via Help->License menu in eTranslator main screen. Both “License To” and “License key” fields
are required.

If you let trial version to expire this will eventually stop software from processing data. Once you decide to purchase the product,
you will receive new permanent license key you can enter in the License screen. This new key will unlock the product without a
need to reinstall it.

If you like the product and decide to purchase it, you will receive new permanent license key that will never expire. Simply enter or
copy and paste new license key in Help->License screen, and restart the program. Same permanent license key can be used to
run translations via command line. However you need special developer license to integrate translator runtime into your programs
and use Developer SDK.

Main Program
You can preview and create output EDI files using main program. Use "File->Open And Translate” menu or Open toolbar button to
open EDlI file.

eTranslator creates output file into the same directory as input file but sets output file extension to “.xml” or “.edi” to the end of file
name. Example: if your input file is called “my271.edi” your output file name will be “my271.xml".
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Drop EDI X12 or XML file here.

License expires in 6 days

There is main eTranslator screen. You can simply drop your EDI files on it. You can not just drop any XML file and expect it
translated into EDI. Your first file must be EDI file. Only then that XML file can be translated back into EDI.

Settings e S

Output File

[] Auto-open file with ¥ML or EDI viewer, or other program assodated with output file extension
Cwverwrite output file if it exists
[7] show additional information as comments in ¥ML (chedk this during initial development)

ok || cancl

There are few options available when opening EDI files. Change them using Settings screen.

Batch Command Line Processing

You can run etranslator as command line batch job. But first you need to execute eTranslator GUI at least once. It will register
license key and EDI standards database.

"C:\full_path_to_executable\etrancmd.exe" -i "C:\test\input270.txt"

Here “-i” followed by space and input file name in double quotes is input file.

Output file name will be automatically created based on input file name. If input file name is EDI then output file name will be XML
and if input file is XML then output will be EDI.

Command line runner returns O if processing run without errors. Non-zero exit code indicates error.
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m Adrministrator CMD | =& x

tranietranc trancmd -1 "d:\temp'204.txt"

Copyright 2011, Etasoft Inc.

iTranslation

Total records
Done

There is command line execution in action.

On some installations command line runner can not find settings set via main eTranslator GUI and will give you “Not licensed”
error. In that case you need to pass path where settings are into command line runner using —u parameter. Parameter -u takes
directory where eTranslator has EDI Standards database and "settings.json" files installed. You can find this directory on most
computers by simply typing

echo %AppData%

in the command line. Environment variable %AppData% + subfolder “eTranslator” should give you string you need to type for
parameter —u.

~_username\AppData‘\Roaming\eTranslatorl

Pass command line —u option that points to settings set via main eTranslator GUI. This is only required if command line runner
can not find settings set via eTranslator GUI.
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B Administrator: CMD | = | ol

FAetrantinstal1h\dist\etrancmds>etrancmd.exe —i "D:\temphproch*.*

Use wildcards to process multiple files in one directory. You can use various wildcards such as “*.*” for all files or “*.xml” for all
XML files.

What Are Invalid EDI Files?

Once you open EDI file in some text editor like Notepad, it looks cryptic. However all valid EDI X12 files have same properties:
1. They all start with three letters: “ISA”
2. After 103 characters there is word “GS”. Sometimes “GS” is on the second line. If “GS” is on the second line then there
might be only 102 characters between “ISA” and “GS".

eTranslator reads and breaks down EDI files using these two points above. Most common scenarios why eTranslator might not be
able to process the file:

1. Thatis notan EDI X12 file. Period. It is flat file, XML or scanned print image form or something else but EDI file.

2. If you copy and paste EDI file from Internet Browser window in most cases resulting EDI file will not be valid anymore.
This is due to how spaces are displayed in the Browsers. Instead of 103 characters between ISA and GS you might end
up having much less.

3. Usually EDIfiles are sent over secure connections using encryption/decryption communications. Sometimes not just
communications but EDI files are encrypted themselves. Encryption leaves ISA/GS part valid but all segments in the file
unreadable. Unless EDI file is decrypted eTranslator will not be able to read it correctly.

4. Some EDI files come from mainframe computer systems. Occasionally they are formatted into columns of 80 characters
long. Extra carriage return and line feed characters break segments into multiple lines making EDI file invalid. Those files
can not be processed.

Results

eTranslator has to produce XML output in a way so it could be assembled back into EDI format. Once you run translator on your
EDI file you will find XML file containing tags named in a special way.
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<xml_edi_wi1> -
E<metadata> [:ﬂ
cidentity>284_BB4A1A_A2145834 X</identitys>
<segmentsep:LF< fsegmentseps
<elementseps*</elementsep?
<uself:Falsed fuself?
<usecrxFalse</usecr>

<style:LooplithTags</style:

F</metadataz
H<data>
<I5A_G@8_B AuthorizationInformationQualifier>B08</ISA B8 A AuthorizationInformationQualifier:
<I5A_688_| AuthorizationInformation:» </I5A_BA_1 AuthorizationInformation:
<I5A_B6 2 SecurityInformationQualifier»B88</I5A_AA 2 Securitylnformationfualifier»
<ISA_A8 3 SecurityInformation: </I5A_B8 3 SecurityInformation:
<ISA_@8 4 TnterchangeIDQualifier»@1</ISA A8 4 TnterchangeIDQualifier:
<I5SA_@8 5 TInterchangeSenderID>B2145834 </I5A_BA 5 InterchangeSenderID:
<ISA_B8 o InterchangeIDQualifier»ZZ</ISA_A8 & InterchangeIDQualifier:
<ISA_AA8_7_InterchangeReceiverID>TEST <fISA 88 _7_InterchangeReceiverID>

<ISA_B68_8 InterchangeDate>1@88719</ISA_B68_8 Interchangebate:
<ISA_BE8_9 InterchangeTime>1146</ISA_B8_% InterchangeTime>
<I5A_AB_18 Repetition5eparator>U</ISA_AB 18 Repetition5eparator:
<ISA_AE_11 InterchangeControlVersionMumber>@8281</I5A_A6_11_TInterchangeControlVersionNumber:
<ISA_@8_12 InterchangeControlNumber:B868862688</I5A B8 12 InterchangeControlNumber:
<ISA_B8 13 AcknowledgmentRequested>1</ISA BA 13 AcknowledgmentRequested:
<ISA_@8_14 TInterchangelsageIndicator>T</ISA_B88_14 InterchangelsageIndicatorz
<I5A_BA 15 ComponentElementSeparator:>}</ISA B8 15 ComponentElementSeparator:
<G5 _5M_ 8 FunctionalldentifierCode>SM</G5 SM B FunctionalIdentifierCode?
<G5_5SM_1 ApplicationSendersCode>@2145834</G5 SM_1 ApplicationSendersCodex
<G5_S5SM_2 ApplicationReceiversCode>TEST</GS_SM_2 ApplicationReceiversCode>
<GS5_SM_3 Date>PB188719</G5 SM_3 Date>
<G5 SM_4 Time>1146</G5 5M 4 Time>
<G5_5M_5 GroupControlNumber:2688< /G5 SM 5 GroupControlNumber:
<G5 _SM_& ResponsiblefAgencyCodexX</G5 SM & ResponsiblefAgencyCode:
<G5 _5SM_7 VersionReleaseIndustryIdentifierCode>BB846818
4fG5_5M 7 VersionReleaseIndustryldentifierCode:
<57_284 8 _TransactionSetIdentifierCode>284</5T7 284 B TransactionSetIdentifierCode:
<57_2684 | TransactionSetControlNumber:268886881</5T_264 1 TransactionSetControlNumber:

[ T LT i o Her =t e o 0 e ST T N W o o i =

eTranslator produces few specific sections required to perform bidirectional translations. Section <metadata> contains important
settings for EDI format translation:

PONPE

o

6.

<identity> tag contains TransactionNumber_Standardsld_Senderld_X information.

<segmentsep> tag contains segment separator.

<elementsep> tag contains element separator.

<uself> tag contains True/False flag indicating if translation from XML back into EDI should add line feed at the end of
each segment.

<usecr> tag contains True/False flag indicating if translation from XML back into EDI should add carriage return at the end
of each segment.

<style> tag is reserved for future versions of eTranslator.

eTranslator creates verbose XML tag names but you can get even more information placed in XML file in a form of a XML
comments. This is useful during development but should not be used for production since it makes XML files even bigger.
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Output File

[] Auto-open file with ¥ML or EDI viewer, or other program assodated with output file extension
[¥] overwrite output file if it exists
[7] show additional information as comments in ¥ML (chedk this during initial development)

ok || cancl

Simply check “Show additional information...” checkbox in the Settings. This will produce additional information in a form of XML
comments.

Performance

eTranslator reads and parses EDI files in computer memory. That puts certain limits on how big input EDI files it can process. Also
since output XML files are more verbose than input EDI files total output size could be 3-7 times greater than input size. Example:
if your input EDI file is 4Mbt your XML output file might be around 30Mbt. This is due to the fact that XML files contain verbose
tags.

Developer SDK

Look under DeveloperSDK subfolder below eTranslator installation main folder.

Technical Support

Please contact technical support if you have any questions or concerns. Contact information is listed on the product and company
websites.
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